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INTRODUCTION TO 
AUGMENTED 
REALITY(AR) / 
VIRTUAL 
REALITY(VR)

• Augmented Reality (AR) is a 
technology that overlays digital 
information—such as images, sounds, 
and other data—onto the real world in 
real-time.

• AR blends the real and virtual worlds, 
allowing users to engage with both 
simultaneously.

•  It enhances the physical environment 
by adding virtual elements, which 
users can see and interact with 
through devices like smartphones, 
tablets, or AR glasses.



VIRTUAL REALITY

• Virtual reality (VR), is an immersive
technology that transports users into computer
generated environments providing a sensory
rich experience that can simulate real world
situation or create entirely new world

• To experience VR the users will have to                  
wear a special headset which has screens 
inside.

• Unlike augmented reality, which blends the 
real and digital worlds, VR creates a fully 
immersive experience where users are 
entirely surrounded by and can interact with a 
virtual world



KEY DIFFERENCES BETWEEN AR AND VR



APPLICATIONS OF AR

• AR-integrated menus (Food & Beverages)

• Medical imaging (Healthcare)

• Warehouse Management (Logistics)

• Interior decoration apps

• Google lens etc.

AR-integrated menus 

Medical imaging

Warehouse Management 

(Logistics)

Google lens

Interior decoration apps



APPLICATIONS OF VR

• Education and training

• Gaming 

• Health care

• Military etc



FUTURE TREND 
OF AR/VR

Some key future trends include:

1. AI AND MACHINE LEARNING 
INTEGRATION:

• Personalized Content: AI customizes 
AR/VR experiences based on individual 
preferences and behaviors.

• Enhanced Interaction: AI improves 
gesture, voice, and eye-tracking, making 
interactions more natural.

• Intelligent Environments: AI-driven 
virtual objects will behave more 
realistically, enhancing immersion.



2.   AR IN EVERYDAY LIFE:

• Smart AR Glasses: The next 
generation of AR glasses will be 
lightweight and resemble regular 
eyewear.

• Retail and Consumer Applications: 
AR will transform the retail 
experience, enabling consumers to 
visualize products in their 
environment before purchasing.



3.   Social and Collaborative VR

• Virtual Workspaces: As remote work 
becomes more common, VR will offer 
virtual office spaces where teams can 
collaborate as if they were in the same 
physical location.

• Social Platforms: People gather in 
virtual spaces for social events, 
gaming, and shared experiences.

• Remote Collaboration: Teams can 
work together in 3D spaces, improving 
productivity and communication.



DIFFERENT SOFTWARE 
AVAILABLE FOR VR 
PRODUCTION

1. Unreal Engine: 

• Best For: Photorealistic VR experiences, architectural 
visualizations etc.

2. Blender:

• Best For: Asset creation and smaller VR projects. While 
not a game engine, it is often used to create assets for VR 
environments.

3. Amazon Sumerian

• Best For: Web-based VR applications. Integration with 
AWS (Amazon Web Services).



WHY UNITY 3D IS 
BEST FOR VR/AR 
PRODUSTION?

1. Ease of Use and Accessibility

• Unity is beginner-friendly with a user 
interface that’s intuitive, making it 
accessible even for non-programmers. 

• It also has a massive community with 
extensive tutorials, documentation, and 
assets, making it easier to learn 
compared to other engines.

2. Cross-Platform Compatibility

• Unity supports a wide range of 
platforms for VR, including Oculus 
Rift, HTC Vive , PlayStation VR, 
Google Cardboard, and mobile 
platforms like iOS and Android. 



3.  Extensive Asset Store

• Unity’s Asset Store offers a wide variety of 
ready-made assets, plugins, and tools that 
speed up the VR development process. 

4. Strong VR Development Tools and   
SDKs

• Unity integrates seamlessly with major VR 
SDKs (Software Development Kits), such 
as Oculus SDK, Steam VR, and Google 
VR SDK. 

• This makes it easier to develop VR 
applications tailored to different hardware 
platforms without starting from scratch.

5. Fast Prototyping

• It  is ideal for rapid prototyping. 

• Developers can quickly test VR 
interactions, visualize environments, and 
iterate changes without waiting for long 
compilation times, making the 
development process more efficient.



OVERVIEW OF UNITY FOR AR/VR

Unity is a cross-platform game 

engine developed by Unity 

Technologies, in 2005.

The focus of unity lies in the 

development of both 2D and 3D 

video games, simulations, and 

interactive experiences.

Unity supports over 20 different 

target platforms for deploying, 

while its most popular platforms 

are the PC, android and iOS 

systems

Unity uses C# as its primary 

scripting language, providing 

developers with powerful tools to 

create complex behaviors and 

interactions within their 

applications.



POPULARITY OF UNITY IN AR/VR DEVELOPMENT

➢Key features of popularity of unity in AR/VR development includes:

a) User-Friendly Interface: Unity offers a highly intuitive and user-friendly interface, making 
it accessible to both beginners and experienced developers.

b) Cross-Platform Support: Unity supports multiple platforms, including major AR/VR 
devices like Oculus and Microsoft HoloLens, allowing for broader reach and compatibility. 

c) Robust Asset Store: Unity’s Asset Store provides a vast library of assets, tools, and plugins 
that speed up

d) Continuous Updates and Improvements: Unity regularly updates its platform with new 
features, performance improvements, and support for emerging technologies development 
and enhance functionality.

e) Strong Community and Resources: Unity has a large and active community, offering 
extensive tutorials, forums, and support that facilitate problem-solving and learning.



Overview of unity’s 
features that 
support AR/VR

• Here's an overview of the key Unity 
features that support AR/VR 
development:

1. XR Interaction Toolkit

• Description: Unity's XR Interaction 
Toolkit provides a framework for 
building AR and VR interactions. It 
includes components for handling 
user input, object manipulation

• Features: Pre-built interaction 
components, support for both 2D 
and 3D user interface(UIs), and 
easy-to-use templates for common 
interactions like grabbing and 
teleportation.



2.  XR Simulator

• Description: The XR Simulator 
allows developers to test AR/VR 
applications without requiring a 
physical device. It simulates device 
input and environmental interactions 
within the Unity Editor.

• Features: Device emulation, 
simulated hand tracking, and 
adjustable environmental conditions.



CONT.. 
3.  Hand and Eye Tracking

• Description: Unity supports 
advanced input methods like 
hand and eye tracking, which 
are essential for creating 
intuitive and immersive AR/VR 
experiences.

• Features: Integration with 
platforms like Oculus, 
Windows Mixed Reality, and 
Magic Leap, support for natural 
hand gestures, and gaze-based 
interactions.



4.  Universal Render Pipeline 
(URP)

• Description: URP is optimized for 
performance and visual quality across 
various devices, making it ideal for 
AR/VR development where 
performance is critical.

• Features: Real-time lighting, post-
processing effects, and shader 
customization with a focus on 
maintaining high frame rates in AR/VR 
environments.



HOW TO INSTALL UNITY SOFTWARE??

• Before installing Unity Engine ,Unity hub is required .

• so first thing is to download unity hub.

• Go to internet browser > unity.com(Official website) as shown in figure1.1

Figure 1.1



Conti…

• The above interface will be opened

Figure 1.2



• Go to plans and pricing(on top left) >(Pick version of unity)>unity 
personal and it will start downloading

Figure 1.3



• In next step it will ask a location where to install unity hub setup

Figure 1.4



• Unity hub set completion

Figure 1.5 Figure 1.6



• Next step is to sign in or create unity  hub account

Figure 1.7



• Next to install unity editor

Figures 1.8



• And downloading completed.



SETTING UP NEW VR PROJECT

1.Create a New Project: 

• Open Unity Hub and click on the "New Project" button.

• Choose a project template (3D is usually sufficient for VR).

• Name the project and choose a location to save it, then click 
“Create Project ”as shown in fig a



Fig. a



• Install VR SDKs: 

• Open the Unity Editor and go to the Window > Package 
Manager. 

• In the Package Manager, search for and install open XR Plugin 
Management shown in Fig b.

• After installation, go to Edit > Project Settings > XR Plug-in 
Management. In the XR Plug-in Management window, check the 
boxes for the VR platforms you want to target (e.g., Oculus, Open 
XR).



Fig. b



3. Configure VR Settings 

• Enable VR Support: In Edit > Project Settings > XR Plug-in 
Management, make sure the appropriate VR plugin is selected for your 
target platform. 

• Adjust other settings in Edit > Project Settings > Player, particularly 
under XR Settings.



Fig. c



4. Set Up VR Controllers and Interactions

• Add VR Interaction SDK:

• Use Unity's XR Interaction Toolkit or Oculus Integration shown in fig d

• Import the necessary package from the Unity Asset Store 

• Set Up Camera and Controllers:

• Replace the default Main Camera with an XR Rig (provided by the XR 
Interaction Toolkit or the SDK one chose) 

• Right click in the hierarchy panel >XR>XR origin shown in fig. e



Fig. d

Fig. e



4. Build Settings: 

• Go to File > Build Settings and choose target platform (PC, 
Android for standalone VR headsets, etc )shown in fig f.

• Ensure the required scenes are added to the build.

• Configure build settings like resolution and quality to match 
your target VR hardware.





UNITY’S INTERFACE



KEY COMPONENTS OF THE UNITY INTERFACE:

1. Scene View:

• Where the user create and arrange game objects.

• Visually placed all assets (cameras, models, and all other pieces and 
objects that make up the game)

2.   Game View : 

• Preview how the scene will look in the actual game.

3.   Hierarchy Window:

• List of all current Game Objects being used in the application



4.   Project Window:

• Displays all the assets (scripts, models, textures) available in the 
project.

• Assets can be dragged into hierarchy window.

5.   Inspector Window:

• Displays properties and settings for the selected object.

6.   Console Window:

• Logs messages, warnings, and errors during development.



Navigation Tips:

• Pan/Zoom/Rotate:

• Use mouse or toolbar  to navigate within the Scene View.

• Shortcuts:

• ‘W, E, R’ for Move, Rotate, and Scale tools.



BUILDING SCENE IN UNITY 3D

➢Introduction to Scene Building:

• A scene in Unity is a collection of Game Objects (like environments, 
characters, and props) arranged in a 3D space.

• Scenes are the foundational elements of any Unity project, 
representing different levels or environments.



STEPS TO BUILD A SCENE:

Step 1: Create a New Scene Go to File > New Scene or use the shortcut 
Ctrl + N. 

• Choose a template if needed (e.g., 3D, 2D, etc.).

Step 2: Add Game Objects Primitive Shapes: 

• Add basic shapes like cubes, spheres, and planes (Game Object > 3D 
Object > Cube)

• .Models and Assets: Import and place 3D models into the scene.

• Terrain: Use Unity’s Terrain tool to create landscapes and 
environments.



Step 3: Organize with the Hierarchy Structure objects in the Hierarchy 
Window for better management. 

• Use parent-child relationships to group objects.

Step 4: Adjust Object Properties .Use the Inspector Window to change 
the position, rotation, and scale of objects.

• Apply materials, shaders, and textures to enhance visual appearance.



Step 5: (Lighting Setup) Add light sources (Directional Light, Point 
Light, etc.) to illuminate the scene.

Step 6: (Camera Setup) Adjust the main camera to frame the scene from 
the desired perspective.

• Use multiple cameras for different views if necessary.

Step 7: Test the Scene Press the Play button to enter Game Mode and 
see the scene in action.

• Use the Game View to check how the scene will look to the player.



Finalizing the Scene: 

• Save the Scene: Go to File > Save Scene or Ctrl + S.

• Scene Management: Use Unity's Scene Manager to load, unload, and 
manage multiple scenes.



GAME OBJECTS 
IN UNITY 3D

A Game Object is the 
fundamental building 
block in Unity.

It can represent anything 
in scene—such as 
characters, props, 
environments, cameras, 
lights. etc 



➢Transform 
Component:

Every Game Object has a 
Transform component. 

It defines the Game 
Object's Position, 
Rotation, and Scale in the 
scene as shown in fig A

Fig. A



➢Collider:

Defines the physical shape 
of the Game Object for 
collisions.

Types include Box 
Collider, Sphere 
Collider(shown in fig B), 
Mesh Collider, essential 
for interaction detection 
(e.g., hitting or triggering) Fig. B



➢Rigid Body:

• Adds physics properties 
to the Game Object.

• Allows the object to be 
affected by gravity and 
forces.

• Controls dynamics like 
velocity and collision 
responses.



➢Script Component:

• Custom scripts (written in 
C#) that control the 
behavior of the Game 
Object.

• Attach C# scripts via the 
Inspector to enable 
interactivity, logic.

➢Light:

• Emits light in the scene.

• Different types include 
Directional Light(shown in 
Fig C), Point Light, 
Spotlight, etc.

FIG C



POSITIONING/SCALING OBJECTS

• Click on object and choose transform

Translate (W)                                                           ROTATE(E)                                            SCALE(R)



MANIPULATING OBJECTS AND CAMERA

1. Panning refers specifically to moving the view around in the Scene.

•  View without changing the camera's position or orientation in the 
game. 

• using the Middle Mouse Button (MMB) .

2. The View Tool (Hand Tool) is the tool in Unity that use to pan.

• Press Q to activate the View Tool.



3.   Camera Setup:

• To control what the 
camera sees, select the 
camera in the Hierarchy 
and use the Transform 
tool to position it as 
shown above fig. D

Fig. D



4.   Scene View Navigation:

• Right Mouse Button: Hold and drag to rotate the view.

• WASD Keys: Move the camera forward, backward, left, or right in the 
scene.

• Mouse Scroll Wheel: Zoom in and out.

• Q/E Keys: Move the camera up or down.



UNITY 
COORDINATE 
FRAME

• In Unity, the concept of 
coordinate frames (or 
coordinate systems) is 
essential for understanding 
how objects are positioned, 
oriented, and moved within 
the 3D space.

• Left hand coordinate system 
as shown in above fig. E 

• Select axes to translate 
object.

Fig. E



ROTATION ABOUT AXIS

• Use rotation tool, select rotation line



UNITY ASSETS STORE

The Unity Asset Store is an online marketplace that offers a wide range of 
assets for Unity developers, including 

• 3D models

• Textures

• Animations

• scripts, sound effects, tools, and more
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